Attention iPhone users: iOS 15.0 through 15.2.x contain bugs that affect the auto-open feature. Versions above or below work fine.

Comments

17 comments

  • Official comment
    Scott Riesebosch

    It already is Elijah. We pushed it out to all devices that are online. The only ones we cannot push it to are the ones that are not online. If yours is online and you don't see the "update firmware" message as shown in the app, you're all set and you can ignore the email.

    Comment actions Permalink
  • Sylvain

    Thanks for the clarification, Scott. Could you share the firmware version so that we can check that everything is okay?

    0
    Comment actions Permalink
  • Scott Riesebosch

    Yes for sure. I just tried to keep the email as simple as possible because I had a feeling if I put the firmware version code in the email I would most likely get bombarded with messages asking how to check the version code. We have an enormous range of customers from the insanely tech savvy to people that need help finding where the settings app / menu is on their phone. So I tried to "walk the line" on the message between those 2 extremes.

    The new firmware is V9.05.

    1
    Comment actions Permalink
  • Sylvain

    Thanks, Scott!

    0
    Comment actions Permalink
  • Elijah Baptiste

    Thanks Scott!

    0
    Comment actions Permalink
  • Brad Wigginton

    My firmware update continually fails. I’ve already rebooted my router, modem and the tailwind device. I also did a full reset of the tailwind and it still fails. Any other suggestions?

    -1
    Comment actions Permalink
  • William Grunwald

    I am also having difficulties updating. I get "Your device will update soon" and nothing else. I've rebooted everything and tried it from both android and IOS apps. I am on vs. 8.33

    0
    Comment actions Permalink
  • daniel tong

    Same here. I'm on version 8.34 on Android but can't get firmware to be updated.

    0
    Comment actions Permalink
  • Scott Riesebosch

    I'm having this investigated. Please leave your Tailwind controllers online. I have also been able to reproduce this issue with these firmware versions.

    0
    Comment actions Permalink
  • Scott Riesebosch

    Ok we found the issue. Should be fixed tomorrow. Please leave your controllers online and they should automatically update by themselves by morning. If you check in the morning and you still see they haven't updated, swipe down to refresh your screen. If "update available" still shows, please tap it and the update should complete. We won't know until the early morning hours if we fixed it or not, but we do know the root cause and we have a plan to address it tonight.

    So sorry for the trouble.

    0
    Comment actions Permalink
  • Scott Riesebosch

    This has been fixed. Please check your firmware now. It may have already been updated. If not, you should be able to update it now.

    0
    Comment actions Permalink
  • Scott Riesebosch

    To clarify, you should see V9.05 once updated. You can find the FW version code by tapping the gear icon to the right of your device on the "My Devices" screen. It's in the field marked "FW"

    0
    Comment actions Permalink
  • William Grunwald

    Looks good, now updated to 9.05... thanks....

    0
    Comment actions Permalink
  • Cynthia Chou

    Hi, I keep getting the "Your device will start update soon" message without an actual update. Is there something I should do? 

     

    0
    Comment actions Permalink
  • Clinton Cocks

    Installed hardware and set up app but says I need the firmware update. Says “your device will update soon” but nothing happens. Has been over 24hrs and still doing the same thing.

    0
    Comment actions Permalink
  • Scott Riesebosch

    Clinton, please contact support@gotailwind.com for further assistance. Cynthia I believe I answered your email :)

    0
    Comment actions Permalink
  • Scott Riesebosch

    Hi Everyone,

    A lot of people have asked me how this could happen - that the firmware can "no longer connect after a certain date". The same thing just happened to Wyze and they ship millions of devices per year. Their new robot vacuums just got smacked with exactly the same thing. I know exactly what the issue is. It's the same one we faced. Super frustrating. I love Wyze products and their company. I have their cameras and sensors. I've preordered their new products. I support them.

    The trouble is that a certain Certificate Authority made a change recently that has substantial implications for a lot of devices and websites. Websites are simple to fix - update the certificate on the server. Solved. Not so simple when a device is out in the wild. You can't log into it and update it. Connecting to that device requires the same security certificate that is no longer valid.

    We are on the other side of the problem and we're taking numerous steps to make sure it never happens again.

    Here's the recent announcement from Wyze.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.